Enforce Server - Error Code 4051 "Agent status attribute batch persist error"
search cancel

Enforce Server - Error Code 4051 "Agent status attribute batch persist error"

book

Article ID: 247198

calendar_today

Updated On: 10-05-2023

Products

Data Loss Prevention Data Loss Prevention Oracle Standard Edition 2

Issue/Introduction

The Error Code 4051  "Agent status attribute batch persist error" is showing in the DLP Enforce Console.

Message

Code: 4051

Summary: Agent status attribute batch persist error

Detail: Status attribute data for 1 agent(s) could not be persisted. Please look at the detection server controller logs for more information.

 

Environment

DLP

Cause

In Monitor Controller log from Enforce Server:

File: Enforce\logs\debug\MonitorController0.log
Date: 7/11/2022 10:43:33 AM
Class: com.vontu.monitor.controller.replicatorcommlayer.applications.agentstatus.AgentStatusAttributeListMarshallablePersister
Method: persist
Level: SEVERE
Message:  Processing of agent: "Machine Name" failed with error code: -1 ORA-00001: unique constraint (PROTECT.AGENTEVENT_N2) violated

Resolution

First run the URT (Upgrade Readiness Tool) to confirm that the Oracle database is clean. Once you have the results, please open a case with support.

The solution with a clean URT is to drop the index AGENTEVENT_N2 and recreate it:

To SEE the list of indexes on AGENT EVENT Table

SELECT * FROM USER_INDEXES WHERE TABLE_NAME='AGENTEVENT';