Advanced Reporting: Error 401 when exporting a report to Excel
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Advanced Reporting: Error 401 when exporting a report to Excel

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Article ID: 247053

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When exporting a report to Excel in Advanced reporting an error 401 is displayed

It happens when exporting any kind of report.

Export to ppt, pdf work fine

Environment

Clarity 16.0.2 and Firefox browser

Cause

The LastPass plugin appears to cause the issue

Resolution

The issue is caused by the LastPass plugin. Disable the plugin to do the export to Excel. If you are unable to disable the add-on, use the incognito mode when reports need to be exported.

This is not a Clarity PPM issue but Tibco's (JS-38127). This is fixed in JRS v7.9

This has been reported to affect Chrome, Edge and Firefox

Please also see:

Exporting report redirected to login page with error relating to CSRF token missing or mismatch

In Clarity 16.1.1 we will introduce JS 8.1.

Tests have been carried out in JS 8.1 and the LastPass related issue is fixed

Additional Information

jasperserver.log/Catalina.log file shows:

potential cross-site request forgery (CSRF) attack thwarted (user:myuser, ip:xxx.xxx.xxx.xxx, method:POST, uri:/jasperserver-pro/flow.html/flowFile/Report.pdf, error:request token does not match session token)