Logfile errors LOCAL502 AND LOPKG002 in new Netmaster region
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Logfile errors LOCAL502 AND LOPKG002 in new Netmaster region

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Article ID: 246902

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Updated On:

Products

NetMaster Network Management for TCP/IP NetMaster File Transfer Management NetMaster Network Automation NetMaster Network Management for SNA Unicenter NetMaster Network Management for SNA SOLVE SOLVE: Access Session Management SOLVE:Central Service Desk SOLVE:Operations Automation

Issue/Introduction

New region. When I logon and do a /LOG I get the following error:

LOCAL502 No Activity Log data files are available

I restarted the region and checked the log and found the following message:

LOPKG002 Log Vartable Error. Procedure:$LOCALL5:SetLog  Action:Add  Vartable:$lo$KeyOrder  FDBK:4 
                            Key:20201009091745520005                                                                 

How can I correct this error?

Environment

Release : All supported SOLVE and Netmaster products

Cause

Record in NMLOG01 conflicts with internal vartable that is expecting an empty log.

Resolution

Logon to the Netmaster region and Issue   /XDB.FILE  from any command line. 

This shows all VSAM files.  If this is a new region, it should show all NMLOG0x at 0% except the one currently in use.
In this case NMLOG01-03 all show 100% allocation.

Selecting one of the logs shows the content with the record key at the beginning. It showed records over 2 years old.

The internal vartable holds the key of the first record from each logfile. With a new region, the vartable would start out empty and thus expect an empty log.
When that did not occur, it put out an error.

The problem was the use of existing, populated NMLOG0x files in the new region.  

The solution was to stop the region and do a DELETE/DEFINE for all NMLOG0x files.

The region initialized correctly and /LOG worked after that.