CA IDM unable to connect to AWS LDAP server
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CA IDM unable to connect to AWS LDAP server

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Article ID: 246728

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Creating User Store Directory in AWS Open LDAP server.  It could not connect to it even though username/password is correct and no problem connecting to the hostname and port

 

"Could not connec to LDAP sever :636 with USer DN uid=idmadmin, ou=ServiceSccounts, dx

Cause

This is due to a Java version upgrade.  Starting from release 1.8.0_181, Java has enabled endpoint identification by default to improve the robustness of LDAPS connections. 

Resolution

Add the line 

JAVA_OPTS="$JAVA_OPTS -Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true
 
during IDM start up.