Services on vApp unable to start due to both *.dodeploy and *.deployed files existing / Failed to reserve shared memory
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Services on vApp unable to start due to both *.dodeploy and *.deployed files existing / Failed to reserve shared memory

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Article ID: 246521

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Updated On:

Products

CA Identity Suite

Issue/Introduction

After standard maintenance restart of vApp, JBoss has both *.dodeploy and *.deployed files and it is preventing the web application servers from starting.

Environment

Release : 14.3, 14.4

Component : IdentityMinder(Identity Manager) Virtual Appliance

Cause

In /opt/CA/wildfly-idm/standalone/log/wildfly-console.log shows information like this:

"Server VM warning: Failed to reserve shared memory."

Resolution

After a routine restart of the VM,  JVM applications were unable to start.

Two versions of files *.deployed and *.dodeploy existed.

Due to file permissions hotfix to delete extra .dodeploy files was provided.

Further issues related to memory were observed.

The issue was caused by the change in memory provided to the machine by Virtualization software (it was reverted to the default amount).

vApp was restored to previous memory values.

The system started and works fine now.