Error when attempting to log into Enforce console
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Error when attempting to log into Enforce console

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Article ID: 246409

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

You encounter the following error when attempting to log in to the Enforce console.

"An unexpected error has occurred. Contact your system administrator if this problem persists."

We see the following errors in the Tomcat localhost logs:

Source: org.apache.ojb.broker.accesslayer.ConnectionFactoryDBCPImpl
Message: Connection close failed
Cause:
java.sql.SQLException: Already closed.java.sql.SQLException: Already closed.

Caused by: org.apache.ojb.broker.accesslayer.LookupException: Could not get connection from DBCP DataSource
 at org.apache.ojb.broker.accesslayer.ConnectionFactoryDBCPImpl.checkOutJdbcConnection(ConnectionFactoryDBCPImpl.java:119)
 at org.apache.ojb.broker.accesslayer.ConnectionFactoryAbstractImpl.lookupConnection(ConnectionFactoryAbstractImpl.java:139)

Caused by: org.apache.commons.dbcp.SQLNestedException: Cannot get a connection, pool exhausted
 at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:103)
 at org.apache.ojb.broker.accesslayer.ConnectionFactoryDBCPImpl.checkOutJdbcConnection(ConnectionFactoryDBCPImpl.java:115)

 

 

Environment

Release : 15.8

Component : Data Loss Prevention Enforce server.

Cause

The commons-dbcp-1.2.1.jar used by the OJB framework for its connection pool implementation has a documented bug:

https://issues.apache.org/jira/browse/DBCP-28

Resolution

The workaround is to restart the Enforce services.

Upgrade the DBCP version to 1.2.2 or higher. The issue has been fixed in DLP 15.8 MP3.