Task Service status: Installed, Inactive
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Task Service status: Installed, Inactive

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Article ID: 246097

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Updated On:

Products

IT Management Suite

Issue/Introduction

After installing the Client Task Server Service on the site server, the status of the task service is Installed but Inactive.  

Error in the task server logs:

Unable to update configuration: x:\Altiris\Altiris Agent\Client Task Server\TaskServer.config
Failed to save config setting in 100 retries @ 00:00:39.8333133, recent error: Could not find a part of the path 'c:\Altiris\Altiris Agent\Client Task Server\3eb05cad-34b4-4236-bca4-b19a3c8b0b6b'.

NOTE: x:\Altiris didn't exist and Altiris was installed on x:\Program files\Altiris! But based on the logs agent was looking in this locarion

Environment

ITMS 8.6

 

Cause

Missing roles and IIS features on the site server. 

 

Resolution

  • Add the missing roles and features to the site server KB 164960
  • uninstall the Task Server
  • Make sure the Client Task Server site is deleted from IIS. If not, delete it manually. 
  • Delete the Client Task Server folder from the installed agent folder (Program Files\Altiris\Altiris Agent)
  • Reinstalled the task server.
  • In IIS make sure the correct certificate is bind for port 443.