Request for Information of How to Manually Delete Device from PM
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Request for Information of How to Manually Delete Device from PM

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Article ID: 245994

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Updated On:

Products

DX NetOps

Issue/Introduction

Can you please send the instructions for how to manually remove a device from PM.

I have looked and cannot find exactly what I am needing.

The device was deleted in our system but somehow remains active and showing in PM, and the user is wanting it to be taken out.

Device on CAPC but not in Monitored devices on the data aggregator 

Device in /rest/devices but not in monitored devices 

Data Aggregator device on the NetOps portal will not delete 

Environment

Release : 20.2

Component : PM Web UI Administration/Configuration

Cause

This was an odd situation. The device was not in monitored devices but was in https://<DA_SYSTEM>:8582/rest/devices/ and the NetOps Portal as device contributed by the Data Aggregator. 

To resolve we deleted the device using curl and ran a full synchronization of the data aggregator. 

Resolution

1. Get the localid (DA itemid) from mysql on the NetOps Portal. 
mysql>select SourceID,ItemID,LocalID,ItemName from dst_device where ItemName="<DEVICE_NAME_FROM_PORTAL>"

2 Run on the DA command line a curl delete using the localid from the above mysql query. 
curl -v  -k -X DELETE -H "Content-Type: application/xml" https://127.0.0.1:8582/rest/devices/<LocalID>