Missing columns for TSVs when reusing fiscal period names
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Missing columns for TSVs when reusing fiscal period names

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Article ID: 245974

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When there are multiple entities using the same fiscal period naming convention (e.g.: all January 2010 monthly periods are named '2010-01'), Modern UX TSVs may not display any period columns.

Steps to Reproduce:

  1. Create 2 or more entities with all requirements (Department, Location...)
  2. For each entity, create monthly fiscal periods (e.g.: 2010 to 2030) and use the same name for matching periods (e.g.: '2010-01' = January 2010 monthly period).
  3. Create a new project and finacially enable it and assign the department and location from one of these entities.
  4. In the Modern UX, open the project and go to Financials > Benefit Plans and create a new benefit plan.
  5. Configure the view to show TSV for Months, from Benefit Plan Start, to Benefit Plan Finish, Sum of Periods and Benefit as Per-Period Metric.
  6. Reload the page while examining the network requests. A REST API request for "fiscalTimePeriods" appears requesting the startDate, endDate and periodName of the start and finish fiscal time periods by the period name and for all Entities.

Expected Results: Only 2 periods should be returned and the REST API filters by entity.

Actual Results: 4 or more periods are returned. The request is also limiting those results to 25, so when there are more than 25 results, chances are that the desired periods are not returned and the TSV columns are not displayed.

Environment

Release : 15.9.1

Component : Clarity MUX UI Usability

Cause

This issue has been reported as DE65919.

Resolution

This issue has been fixed in Clarity 16.0.3 patch #1 and 16.1.0.