Timesheet review portlet time Periods filter not functioning correctly
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Timesheet review portlet time Periods filter not functioning correctly

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Article ID: 245905

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The Timesheet review portlet displays data for all time sheets from both open and closed time periods in the system whereas the 'Time Period' field in filter section shows only open time periods. This behavior is inconsistent with grid and filter section.

Steps to Reproduce:

  1. Navigate to Home -> General in Classic
  2. Click on Personalize/Add Tab icon
  3. Add a new Tab, name it Timesheets Overview
  4. Add Content, Filter for Time and Find Timesheet Review, then Return and return
  5. Click on Timesheets Overview tab
  6. Expand the Filter
  7. Click on Time Periods filter

Expected: To see all the open and closed Time periods in the system

Actual: Only open Time periods are visible

Environment

Release : 16.0.2

Component : Clarity Time Management

Cause

Due to defect DE65811.

The lookup ‘COP_PORTLET_TIMESHEET_PERIOD’ used by Time Period field has condition to filter for open time periods whereas the NSQL used by the portlet doesn’t have any filter as such.

Resolution

Fixed in 16.0.3 version.