WorkPoint jobs import failures on &# characters
search cancel

WorkPoint jobs import failures on &# characters

book

Article ID: 245869

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Exporting a Workpoint Job XML is successful but trying to import that XML fails because of the &# characters.

For example the exported XML shows 

<var_name>PARTICIPANTS</var_name><var_value>[email protected]&#31;&#31;[email protected]&#31;</var_value>

 

 

 

 

Environment

Identity Manager 14.4 and later

Cause

IM 14.2 included WorkPoint 3.52 where as IM 14.4 now includes WorkPoint 4.4 so behavior differences with WorkPoint Designer exports could be related to different WorkPoint versions versus IM itself.

Resolution

Solution 1

In WorkPoint Designer edit and save the job so that you edit the participants attribute to delete the existing separator character &#31; which shows up as a space in the interface (albeit with a greater width) and then insert a whitespace instead for each &#31; character sequence. Now export the job and verify the absence of &#31; characters in the XML file and then the XML file can be imported successfully.

Solution 2 - 

In WorkPoint Designer export the job and manually edit the XML file to replace each &#31; character sequence with a whitespace instead and then the XML file can be imported successfully.