AMD Causing High CPU usage in Data Center Security Server Agent
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AMD Causing High CPU usage in Data Center Security Server Agent

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Article ID: 245784

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

There is a known issue with the 6.9.1 and 6.9.2 branches where the agent is scanning the external drives even when scanning external drives is disabled.

 

Environment

Release : 6.9.1 & 6.9.2

Cause

The logic to scan external drive (enable/disable) setting is reversed in implementation

amdmanagement.scan.external.drive=enable

Resolution

Workaround for customer:

Stop AMD service
sed -i 's/amdmanagement.scan.external.drive=disable/amdmanagement.scan.external.drive=enable/g' /opt/Symantec/sdcssagent/AMD/system/AntiMalware.ini
Start AMD service

OR 

DCS "Scan External Drive" option can be updated from "Management Console" with below path

Management Console -> Configs -> Default Detection Parameters -> Select tab "AV Config" -> Enable (Check) option Scan External Drive

And on client machine verify that the option is updated in the following configuration file:


vi /opt/Symantec/sdcssagent/AMD/system/AntiMalware.ini

[AMDManagement]
...
amdmanagement.scan.external.drive=enable