Addressing High CPU Usage in Data Center Security Server Agent Due to AMD Compatibility
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Addressing High CPU Usage in Data Center Security Server Agent Due to AMD Compatibility

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Article ID: 245784

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

There is a known issue with the 6.9.1 and 6.9.2 branches where the agent scans external drives even when scanning external drives is disabled.

Environment

Release : 6.9.1 & 6.9.2

Cause

The logic for the external drive scanning (enable/disable) setting is reversed in implementation.

amdmanagement.scan.external.drive=enable

Resolution

Workaround:

Stop the AMD service.
Update the setting in the AntiMalware.ini file by executing the command:

sed -i 's/amdmanagement.scan.external.drive=disable/amdmanagement.scan.external.drive=enable/g' /opt/Symantec/sdcssagent/AMD/system/AntiMalware.ini

Restart the AMD service.

OR

Update the "Scan External Drive" option in the DCS Management Console:
Navigate to Management Console -> Configs -> Default Detection Parameters -> Select the "AV Config" tab -> Check the option for "Scan External Drive."

On the client machine, verify that the option is updated in the following configuration file:

vi /opt/Symantec/sdcssagent/AMD/system/AntiMalware.ini

[AMDManagement]
...
amdmanagement.scan.external.drive=enable