Error: 404 - After Upgrade to 21.2.12 Logout from Performance Management generates 404 error.
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Error: 404 - After Upgrade to 21.2.12 Logout from Performance Management generates 404 error.

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Article ID: 245669

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

After Upgrade to 21.2.12 DX NetOps Portal logout is not working properly. We get the following error message:

In PCService.log I found the following message:

WARN  | qtp21793344-5316         | 2022-06-29 13:31:49,210 | com.ca.im.portal.AuthenticationFilter
      | Unable to retrieve SsoToken

Restart of services didn't solve the problem.

Environment

Release : 21.2

Component : NetOps Portal web server

Cause

You are not using the hostname to access the page ; instead you access the UI using the IP address

AND/OR

You are not using the correct URL to access the page

Resolution

  • Always use the configured Hostname to access the UI
  • Always use the supported URL to access the UI:
    • http://<hostname>:8181/pc/desktop/page
    • https://<hostname>:8182/pc/desktop/page

Additional Information

Check Hostname using the SsoConfig utility:

/opt/CA/PerformanceCenter/SsoConfig

SSO Configuration:
1. DX NetOps
Choose an option > 1

SSO Configuration/DX NetOps:
1. LDAP Authentication
2. SAML2 Authentication
3. Performance Center
4. Single Sign-On
5. Test LDAP
6. Export SAML2 Service Provider Metadata
7. Enable FIPS
8. Performance Center Local Password Authentication
9. Enable or Disable a user account.
Choose an option > 3

Web Site Scheme: http
Web Site Host: <hostname>
Web Site Port: 8181
Web Site Path: /pc/desktop/page