Forgotten Password and Forgotten Username tasks inaccessible
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Forgotten Password and Forgotten Username tasks inaccessible

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Article ID: 245568

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

After clicking on "Forgotten Password?" or "Forgotten Username" option on IM user console login screen user is redirected to the address that doesn't work

Example:

FQDN:port/iam/im/identityenv//pubidentityEnv/ui7/index.jsp?task.tag=taskname

If you remove: /identityenv/ the redirect will work.

Example:

hostname:port/iam/im/pubidentityEnv/ui7/index.jsp?task.tag=taskname

if you switch hostname to FQDN it works.

Example:

On the login page if you click "Not able to access your account?" you are redirected to the page with the correct address, but showing an error about the task.

FQDN:port/iam/im/pubidentityEnv/ui7/index.jsp?task.tag=unlockuser

Environment

Release : 14.5

Component : Identity Manager, Virtual Appliance 

Cause

The base URL of the environment is provided incorrectly.

 

Resolution

Base URL should be changed in IM Management Console - Environments - Environment name 

Remove part causing issues, in the first example from:

http://FQDN:port/iam/im/identityenv/

to:

http://FQDN:port/iam/im

 

In the second example from:

http://hostname:port/iam/im

to:

http://FQDN:port/iam/im

if you switch hostname to FQDN it works fine

 

Save changes and then restart the environment

The third example means there is no task with such a tag as 

unlockuser

Create or modify the task so it has such a tag.