Modify URL policy action causes messages to be queued in bad message queue
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Modify URL policy action causes messages to be queued in bad message queue

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Article ID: 245413

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Updated On:

Products

Messaging Gateway

Issue/Introduction

After enabling policies that take the "Modify Clickable URL" action you get alerts from Messaging Gateway indicating that messages have been placed in the Bad Message queue. Reviewing the logs you find entries like the following in the Brightmail Client log (bmclient_log):

2022-07-06T16:36:07-07:00 (INFO:51707.983222016): [46022] Transforming message with MTE action Clicker.
2022-07-06T16:36:07-07:00 (WARNING:51707.983222016): [46037] The message body could not be decoded from quoted-printable format.
2022-07-06T16:36:07-07:00 (ERROR:51707.983222016): [46039] Could not copy the message body.
2022-07-06T16:36:07-07:00 (ERROR:51707.983222016): [46059] Unable to modify URL's in message body: Error 46039.

Environment

Release : 10.7.5 patch 10.7.5-292

 

Cause

Messages that are encoded as "quoted-printable" data but which do not conform to the quoted printable data standard cannot be safely modified by URL modification. In previous releases the default behavior for these messages was to allow them to pass unmodified but with SMG 10.7.5 with patch 10.7.5-292 applied, these messages are taken out of the mail stream and placed in the bad message queue for administrative action.

Resolution

There is currently no workaround for this issue other than to take a policy action other than Modify URLs.

Additional Information

The bad message queue can be managed using the command line tool mta-control. 

Deleting all messages from the bad message queue:

mta-control all bad-msg-delete all