data_engine probe queued up and not processing QOS messages
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data_engine probe queued up and not processing QOS messages

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Article ID: 245358

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The data engine is queued up and QOS messages are not being processed.

Environment

Release : 20.3, 20.4 or higher

Component : UIM - DATA_ENGINE

Cause

It was observed that a script was blocking, and that was preventing data inserts into the UIM database.

Upon analysis, it was observed that the database maintenance script and indexing script was scheduled at the same time, and this was causing the issue. 

Resolution

Schedule the database maintenance script and indexing script to run at different times.

Data maintenance script that data_engine uses runs at 12:40 am. Indexing should not run at the same time.

Note that auto indexing is fine for small UIM environments but should be disabled in medium-to-large environments.

Table partitioning is sufficient to maintain the tables so partitioning should be enabled but large tables should be manually partitioned first before enabling the option in the data_engine.

Additional Information

How to manually partition the UIM database for MS SQL Server

How to manually partition the UIM database for Oracle

How to manually partition the database for MySQL