Unable to login to enforce console using AD login or Administrator account
search cancel

Unable to login to enforce console using AD login or Administrator account

book

Article ID: 245355

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

Customer is not able to login to enforce console using AD account as well as Administrator account. Tomcat localhost logs have below errors -

Thread: 57653 SEVERE [com.vontu.manager] Unable to perform login for user: Domain\username
Cause:
org.apache.ojb.broker.PersistenceBrokerException: org.apache.ojb.broker.PersistenceBrokerSQLException:
* SQLException during execution of sql-statement:
* sql statement was 'SELECT A0.roleID,A0.name,A0.description,A0.isDeleted,A0.version,A0.isActiveDirectoryManaged,A0.directoryGroupID,A0.lastAdSyncTime FROM UserRoleMapping M_N, Role A0 WHERE (M_N.userID = ?) AND M_N.roleID = A0.roleID'
* Exception message is [No more data to read from socket]
* Vendor error code [17410]
* SQL state code [08000]org.apache.ojb.broker.PersistenceBrokerException: org.apache.ojb.broker.PersistenceBrokerSQLException:
* SQLException during execution of sql-statement:
* sql statement was 'SELECT A0.roleID,A0.name,A0.description,A0.isDeleted,A0.version,A0.isActiveDirectoryManaged,A0.directoryGroupID,A0.lastAdSyncTime FROM UserRoleMapping M_N, Role A0 WHERE (M_N.userID = ?) AND M_N.roleID = A0.roleID'
* Exception message is [No more data to read from socket]
* Vendor error code [17410]
* SQL state code [08000]
 at org.apache.ojb.broker.core.proxy.CollectionProxyDefaultImpl.loadData(CollectionProxyDefaultImpl.java:203)
 at org.apache.ojb.broker.core.proxy.ListProxyDefaultImpl.loadData(ListProxyDefaultImpl.java:148)
12:39
Caused by: org.apache.ojb.broker.PersistenceBrokerSQLException:
* SQLException during execution of sql-statement:
* sql statement was 'SELECT A0.roleID,A0.name,A0.description,A0.isDeleted,A0.version,A0.isActiveDirectoryManaged,A0.directoryGroupID,A0.lastAdSyncTime FROM UserRoleMapping M_N, Role A0 WHERE (M_N.userID = ?) AND M_N.roleID = A0.roleID'
* Exception message is [No more data to read from socket]
* Vendor error code [17410]
* SQL state code [08000]
 at org.apache.ojb.broker.util.ExceptionHelper.generateException(ExceptionHelper.java:256)
 at org.apache.ojb.broker.util.ExceptionHelper.generateException(ExceptionHelper.java:90)
 at org.apache.ojb.broker.util.ExceptionHelper.generateException(ExceptionHelper.java:71)
 at org.apache.ojb.broker.accesslayer.JdbcAccessImpl.executeQuery(JdbcAccessImpl.java:307)
 at org.apache.ojb.broker.accesslayer.RsQueryObject.performQuery(RsQueryObject.java:72)
12:39
Caused by: java.sql.SQLRecoverableException: No more data to read from socket

 

Resolution

1. Stop all the Enforce server services.

2. Restart the Oracle DB services.

3. Start the Enforce server services.

Verify login once the enforce console is up and running.