LiveUpdate task is failing on Endpoint Protection Manager with return code 4
search cancel

LiveUpdate task is failing on Endpoint Protection Manager with return code 4

book

Article ID: 245258

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Scheduled and manual LiveUpdate task is failing on Endpoint Protection Manager (SEPM) with return code 4.

Proxy is required for https/http connection on the SEPM server. Livetri.zip is getting downloaded successfully through the browser using the same proxy details in Internet Options.

Details of proxy server is provided correctly under Proxy server settings in Server Properties (Admin> Servers, click on SEPM site then Edit the Server Properties, Proxy Server tab with 'Use custom proxy settings' in "Proxy usage:") 

However as per lux.log, connection is not attempted through the specified proxy server.

Following error is found in lux.log: 

18:04:40.304667 Result Code: 0x80010830
18:04:40.304667 Result Message: FAIL - failed to select server
18:04:40.304667 [Server - START]
18:04:40.304667 Host ID: {55C395A6-F5AB-47A5-9ED7-D3D85108E6F5}
18:04:40.304667 Status Code: 1 18:04:40.304667 Status Message: Server was not selected
18:04:40.305667 Transport Return Code: 0x80010731
18:04:40.305667 Transport Return Message: FAIL - download failed
18:04:40.305667 Protocol: HTTPS
18:04:40.305667 Hostname: liveupdate.symantecliveupdate.com
18:04:40.305667 Port: 443
18:04:40.305667 Path:
18:04:40.305667Proxy ID: {00000000-0000-0000-0000-000000000000}
18:04:40.305667 Proxy Bypass: false
18:04:40.305667 	[Server - END]
18:04:40.306665 	[Server - START]
18:04:40.306665 		Host ID: {3C7308B4-CB65-4FC3-8D72-15591EA12E1C}
18:04:40.306665 		Status Code: 1
18:04:40.306665 		Status Message: Server was not selected
18:04:40.306665 		Transport Return Code: 0x80010731
18:04:40.306665 		Transport Return Message: FAIL - download failed
18:04:40.306665 		Protocol: HTTPS
18:04:40.306665 		Hostname: liveupdate.symantec.com
18:04:40.306665 		Port: 443
18:04:40.307665 		Path: 
18:04:40.307665 		Proxy ID: {00000000-0000-0000-0000-000000000000}
18:04:40.307665 		Proxy Bypass: false
18:04:40.307665 	[Server - END]
18:04:40.307665 	Used proxy list was empty
18:04:40.307665 [Server Selection - END]
18:04:40.307665 [Finalize Session - START]
18:04:40.308666 	Result Code: 0x00010000
18:04:40.308666 	Result Message: OK
18:04:40.308666 	Component Status Changes:
18:04:40.309666 		None
18:04:40.309666 [Finalize Session - END]
18:04:40.310666 [Session Results - START]
18:04:40.310666 	Session Result Code: 0x80010830
18:04:40.310666 	Session Result Message: FAIL - failed to select server

Got the same issue with http link for LiveUpdate server under Site Properties> Edit Source Servers.

 

Used PsTools and entered the proxy details in IE for computers system context following Article ID: 214506, it did not make any difference. 

Cause

Connection to LiveUpdate server was not going the specified proxy server and failing to run the task

Resolution

On further review in this scenario, found that there are two sem server blocks with same server id.

<SemSite Id="0FBB62280A0E1019002CB49112D7587D" Name="Site SERVER_NAME" Description="" CreationTime="1345603481596" Suspended="0" EnableSymQual="1" NameSpace="schema" _i="D3B021C80A0E1019016D383AE3C44066" _t="1646636382007" _d="false" _v="136">
…
<ServerArray NameSpace="schema" _i="065D71320A0E101901AEFD7B0B2354BF" _t="1501846245374" _d="false" _v="4">
<SemServer Id="8DC7A272AC1F05190074F356EEAF97F9" Name="10.xx.xx.xx" Description="" CreationTime="1345603481596" CompanySize="0" NameSpace="schema" _i="5A67F5310A0E10190183D08C41A44E80" _t="1498702925709" _d="false" _v="46">
…
<TransportServerCertificate CertName="SERVER_NAME" NameSpace="schema" _i="F598C6230A0E1019012BC418708ECDD3" _t="1415676992097" _d="false" _v="19">MIICPzCCAaigAwIBAgIETAYWKTANBgkqhkiG9w0BAQUFADBkMQswCQYDVQQGEwJVUzELMAkGA1UE&#x0D;
…
</SemServer>
<SemServer Id="8DC7A272AC1F05190074F356EEAF97F9" Name="SERVER_NAME" Description="" CreationTime="1501837275494" CompanySize="0" NameSpace="schema" _i="BFB4F0A20A0E101901C2595F46A1DA4E" _t="1646637442619" _d="false" _v="103">
…

LiveUpdate process was considering configuration from first server(Name="10.xx.xx.xx") and update of proxy config is going to seconder server(Name="SERVER_NAME").

Contact support to get a tool for deleting the server name with incorrect details.