Task doesn't show active in SOLVE:Operations
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Task doesn't show active in SOLVE:Operations

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Article ID: 245209

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Updated On:

Products

SOLVE:Operations Automation

Issue/Introduction

When SOLVE:OPS initializes, automated tasks don't show  as ACTIVE. Issuing a check command (CHK) corrects the status in the resource manager.
Similarly, if a task goes down during the day, this is not reflected for that task in the resource manager; it still shows ACTIVE. 

This is making monitoring unreliable.

Environment

Release : 11.9

Component : SOLVE:Operations Automation for z/OS

Cause

Root cause was that the Message Learning Table was not honoring the maximum number of records defined in the AUTOTABLES parameter group (3000), and the database had very slowly increased in size to the point that internal tables were failing during load of the system image due to a lack of available storage in the product. Only messages logged for this were

RMMF0102 ALLOC ERROR ON TABLE($RMSSIFILTER) FDBK(24) KEY()
RMMF0102 ALLOC ERROR ON TABLE($RMSSIFILTER) FDBK(24) KEY()

but they were buried in among thousands of other initialization messages, so were missed. 

Resolution

Disable message learning and delete the database.

To do so:
Change the description for the active RULESET  to 
Collect Statistics? .......... NO  
Learn New Messages? .......... NO   

Delete the entire Message Learning database - /EADMIN.L (Message learning), then option D to delete.

Recycle the region.

 
LU05826 will prevent this problem from occurring, but does not repair the problem if it already exists, so the steps above may need to be taken.