WSS Agent not requiring a password to uninstall when it should do
search cancel

WSS Agent not requiring a password to uninstall when it should do

book

Article ID: 245161

calendar_today

Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

WSS Agent installed on Windows host.

WSS Agent settings requires an uninstall token to successfully remove the product.

When uninstalling, the WSS agent does not ask for a password.

Tested the same on two different WSS instances.

Environment

WSS Agent

Cause

WSS Agent host needs to connect to CTC at least once to learn about uninstall token

Resolution

Make sure that agent connects to WSS at least once before uninstalling, to get uninstall token details for tenant.

 

Additional Information

User was testing on a device with no internet access so the agent was being installed and then uninstalled without ever connecting to WSS.

Once connected, passphrase info is available available and uninstall completed successfully.