IM connector in Identity Portal is unable to start due to Read Timed Out error
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IM connector in Identity Portal is unable to start due to Read Timed Out error

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Article ID: 245130

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Updated On:

Products

CA Identity Suite

Issue/Introduction

After applying CHF_IP-14.4.1-20220204155757-CHF001.tgz.gpg cumulative hot fixes, IM connector in Identity Portal is unable to start. IP server log shows the following "Read Timed Out" error.

2022-06-22 19:08:40,027 ERROR [com.idmlogic.sigma.connector.ca.CaimAdapterBase] (default task-5) Reload connector failed : java.lang.RuntimeException: javax.ws.rs.ProcessingException: java.net.SocketTimeoutException: SocketTimeoutException invoking http://caim-srv:80/iam/im/ws/identityEnv/portal/test: Read timed out
 at com.idmlogic.sigma.connector.ca.CaimAdapterBase.start(CaimAdapterBase.java:79)
 at com.idmlogic.sigma.connector.ca.CaimAdapterBase.reload(CaimAdapterBase.java:95)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

...

Caused by: javax.ws.rs.ProcessingException: java.net.SocketTimeoutException: SocketTimeoutException invoking http://caim-srv:80/iam/im/ws/identityEnv/portal/test: Read timed out
 at org.apache.cxf.jaxrs.client.AbstractClient.checkClientException(AbstractClient.java:600)
 at org.apache.cxf.jaxrs.client.AbstractClient.preProcessResult(AbstractClient.java:577)

...

Caused by: java.net.SocketTimeoutException: SocketTimeoutException invoking http://caim-srv:80/iam/im/ws/identityEnv/portal/test: Read timed out
 at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
 at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)

...

Caused by: java.net.SocketTimeoutException: Read timed out
 at java.net.SocketInputStream.socketRead0(Native Method)
 at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
 at java.net.SocketInputStream.read(SocketInputStream.java:171)

There is no corresponding error on IM server log.

Environment

Release : 14.4.x

Component : Identity Portal, CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

The default "Portal IM Client timeout (milli seconds)" parameter value is not sufficient for IM Connector to load.

Resolution

Increase "Portal IM Client timeout (milli seconds)" parameter value

1. Log in to the IP Admin Console as portaladmin user
2. Click on Setup --> Connectors --> Problematic IM Connector.
3. The wizard will open. Navigate to the web services tab. Click on "Show Advanced Properties".
4. Double the "IM Client Timeout value" If the value is not there, enter 2 minutes (120000).
5. Click Next...Save.
6. Start the connector.

Increase the value more if necessary. This should address the issue.

Additional Information

IP will load IM tasks and cache them when IM Connector is started. It seems the cumulative hot fixes makes IP load more and require more time during this initialization step.