Unable to install Inventory 8.6 RU2 plug-in
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Unable to install Inventory 8.6 RU2 plug-in

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Article ID: 245083

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Updated On:

Products

Inventory Solution

Issue/Introduction

This is the scenario as it was reported:

1. The Notification Server was upgraded to ITMS 8.6 RU2 recently.
2. Trying to setup new client machines by sending the usual installation policies for the desired plug-ins.
3. Everything goes smoothly until it is the turn for the Inventory plug-in (8.6.3268 version) task to install. It runs and the customer gets a "run failed" status. This is happening just to some client machines.
4. If you run the Inventory plug-in MSI manually, it installs just fine. 
5. The agent logs (attached here with verbosity turned on as well) show things like these (the customer cloned the Inventory plug-in install policy twice just to make sure it was not something wrong with the first one):

Program 'Test of Inventory Plug-in Install' completed. Exit code=1. Execution context='Administrator'. RunAs='\'
-----------------------------------------------------------------------------------------------------
Date: 6/20/2022 12:55:00 PM, Tick Count: 1113015937 (12.21:10:15.9370000), Size: 341 B
Process: AeXNSAgent.exe (1800), Thread ID: 14768, Module: smfagent.dll
Priority: 4, Source: ProgramExec

Advert 'Inventory Plug-in for Windows Install (x64)' {8C055B3A-653D-40A0-8666-5C9B604A8872} NOT active and has already executed. Package 'Inventory Plug-in for Windows Package (x64)' {5864027D-DA99-4430-9183-4EFF8B362383} might be set to expired...
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Date: 6/20/2022 1:14:33 PM, Tick Count: 1114188828 (12.21:29:48.8280000), Size: 489 B
Process: AeXNSAgent.exe (1800), Thread ID: 14428, Module: smfagent.dll
Priority: 16, Source: CleanupExpiredPackages

Package 'Inventory Plug-in for Windows Package (x64)' {5864027D-DA99-4430-9183-4EFF8B362383} is used in the advert 'Test of Inventory Plug-in Install' {B8B58D3D-2937-40D7-8BB0-1336C2E45E48}...
-----------------------------------------------------------------------------------------------------
Date: 6/20/2022 1:14:33 PM, Tick Count: 1114188828 (12.21:29:48.8280000), Size: 433 B
Process: AeXNSAgent.exe (1800), Thread ID: 14428, Module: smfagent.dll
Priority: 16, Source: CleanupExpiredPackages
 
6. The "log.txt" generated (usually under "C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{5864027D-DA99-4430-9183-4EFF8B362383}\cache") when the install batch runs says the following:
 
started "Symantec_InventoryAgent_x64.msi" installation
started setting variables
stopped setting variables
started setting INV_AGENT_PATH
INV_AGENT_PATH = ""
started MSIEXE /i command
stopped MSIEXE /i "Symantec_InventoryAgent_x64.msi" /qn REBOOT=ReallySuppress ALLUSERS=1 command, error code = 1
exiting
Final error code = 1
 
7. If you run the following on a command prompt, the Inventory plug-in installs just fine:
  MSIEXE /i "Symantec_InventoryAgent_x64.msi" /qn REBOOT=ReallySuppress ALLUSERS=1 
 

Environment

ITMS 8.5, 8.6

Cause

The problem is in the installation BAT file (InstallInvAgent.bat usually under "C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{5864027D-DA99-4430-9183-4EFF8B362383}\cache" on the client machine or under the original package: "C:\Program Files\Altiris\Notification Server\NSCap\bin\Win64\x64\Inventory\Agent Package"). The installation itself finishes just fine, it is the script that passes the incorrect exit code.

Resolution

This issue has been reported to our Broadcom Development team. A fix has been added to our ITMS 8.6 RU3 release and later.

A workaround is to replace the original InstallInvAgent.bat with the attached one in this article and try manually to install the Inventory plug-in (just to make sure it works for you on those specific machines):

  1. On the client machine, go to <\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{5864027D-DA99-4430-9183-4EFF8B362383}\cache
  2. Copy the "Symantec_InventoryAgent_x64.msi" and save it in a different folder of your choosing. 
  3. Place the attached "InstallInvAgent.bat" on the same directory as the "Symantec_InventoryAgent_x64.msi" 
  4. From the command prompt, navigate to the directory where you placed the files from steps 2 and 3. Run the following command:

    InstallInvAgent.bat "Symantec_InventoryAgent_x64.msi"

  5. Check that the Inventory plug-in got installed (you can see that under the "Agent Settings" tab on the Agent UI).

 

Attachments

1656606970923__InstallInvAgent.bat get_app