Knowledge documents are not searchable
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Knowledge documents are not searchable

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Article ID: 244991

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Knowledge Document aren't shown in Service Point

Unable to search for knowledge documents in Service Point.  

The documents are listed in SDM

 

Steps to reproduce:

Log into Service Point 

Type a category or question in the search bar.

In Service Point you will see "There are no suggestions that match your search criteria"

searchMS.log

INFO - 2022-06-29 10:16:31 [controllers.SuggestedSolutions] - ticketId: [null], objectName: [suggestedSolutions], tenantId: [null], noOfRows: [20]
INFO - 2022-06-29 10:16:31 [controllers.SuggestedSolutions] - Authentication - userId:, roleId:[10005]
INFO - 2022-06-29 10:16:31 [c.CategoriesSearchController] - searchString: [troubleshooting], objectName: [pcat] noOfRows: [40]
INFO - 2022-06-29 10:16:31 [es.SearchHelper] - Connected with Elastic Search Server: [http://hostname:9012/sp_index_autocat_search/_search]
INFO - 2022-06-29 10:16:31 [es.SearchHelper] - Connected with Elastic Search Server: [http://hostname:9012/sdm_index_kd/_search]
INFO - 2022-06-29 10:16:32 [es.SearchHelper] - Connected with Elastic Search Server: [http://hostname:9012/sdm_index_pcat,sdm_index_cr,catalog_index_service_offering/_search]
INFO - 2022-06-29 10:16:32 [controllers.SuggestedSolutions] - Only KDs - Total number of results from ES [104]
INFO - 2022-06-29 10:16:32 [controllers.SuggestedSolutions] - No of results from Domsrvr: [0]
INFO - 2022-06-29 10:16:32 [controllers.SuggestedSolutions] - Only KDs - Though we didn't receive number of results we wanted, we are not going with searching ES and going to Domsrvr again! 

Or

ERROR - 2022-08-23 09:01:07 [c.CategoriesSearchController] - No authorized catagory or offering found for this user.

 

Environment

Release : 17.3 or higher

Component : SDM - Service Point

Cause

Employee role is not set to view Knowledge documents

Resolution

Service Desk Manager >Administration tab > Security and Role management > Functional Access > Knowledge Document >  

Edit in list > Employee and change the Access Level to "View"

 

Refresh Service Point attempt your search again