Added new nodes to cluster and getting errors unable to login to Identity manager - incorrect user or password
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Added new nodes to cluster and getting errors unable to login to Identity manager - incorrect user or password

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Article ID: 244963

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

After adding two new nodes to our cluster to upgrade the CentOS8 from CentOS6. Everything appeared to be installed perfectly fine, but now it seems like I cannot sign into the Identity Manager. No user scan sign into the IdentityEnv environment and it reports "incorrect user or password."

When all the services on the two new CentOS8 servers are stopped, login works fine. But when The CentOS nodes are running the problem ocurrs.

Cause

In JXplorer we saw that when accessing the userstore directory via the new router dsa (on new CentOS8 server) that the user's records listed schema attribute reference numbers instead of the actual attribute names. This was preventing the users from fully authenticating.

In looking through the schema file in /dxserver/conf/schema we found that the customized im_user_aux.dxc was missing on  the new CentOS8 server that hosted the userstore router DSA. It contained only the default version of im_user_aux.dxc.

 

Resolution

Review the DSA schema files (in /dxserver/conf/schema) on all nodes to ensure they all have the same content.

Copy the correct, modified, custom version of im_user_aux.dxc (or other incorrect schema file) from the working CentOS6 node to the new CentOS6 node that is running the im userstore router.