DX Netops Spectrum reports in CABI fail with error after upgrading CABI to 7.9.x
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DX Netops Spectrum reports in CABI fail with error after upgrading CABI to 7.9.x

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Article ID: 244889

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Error seen:

java.sql.SQLSyntaxErrorException: Could not connect to address=(host=hostname.domain)(port=3306)(type=master) : Access denied for user 'CR_user'@'hostname.domain' to database 'srmdbapi&allowPublicKeyRetrieval=true'
at org.mariadb.jdbc.internal.util.exceptions.ExceptionMapper.get(ExceptionMapper.java:243)
at org.mariadb.jdbc.internal.protocol.AbstractConnectProtocol.connectWithoutProxy(AbstractConnectProtocol.java:1241)

Environment

Release : 21.2

Component : Jaspersoft for CA Spectrum

Cause

Misconfigured datasource out of the box

Resolution

Login to CABI as "superuser".

Select Data Sources

Then find and edit the spectrum datasources (right click -> Edit):

In the edit screen, change the & to a ? in the URL:

Save the settings.

Reports should now work successfully.

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