DX Netops Spectrum reports in CABI fail with error after upgrading CABI to 7.9.x
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DX Netops Spectrum reports in CABI fail with error after upgrading CABI to 7.9.x

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Article ID: 244889

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Error seen:

java.sql.SQLSyntaxErrorException: Could not connect to address=(host=hostname.domain)(port=3306)(type=master) : Access denied for user 'CR_user'@'hostname.domain' to database 'srmdbapi&allowPublicKeyRetrieval=true'
at org.mariadb.jdbc.internal.util.exceptions.ExceptionMapper.get(ExceptionMapper.java:243)
at org.mariadb.jdbc.internal.protocol.AbstractConnectProtocol.connectWithoutProxy(AbstractConnectProtocol.java:1241)

Environment

Release : All supported releases

Component : Jaspersoft for CA Spectrum

Cause


Jaspersoft appends &allowPublicKeyRetrieval=true to the database connection string. It is possible jaspersoft is incorrectly assuming that there
   are other post variables and it is appending one more. Since this is the first post variable '?' is needed after the database name and before the first variable.

This appears to happen after a restart of tomcat on the OneClick/SRM server.

Resolution

Login to CABI as "superuser".

Select Data Sources

Then find and edit the spectrum datasources (right click -> Edit):

In the edit screen, change the & to a ? in the URL:

Save the settings.

Reports should now work successfully.

The customer can disable the Spectrum-CABI integration. All functionality will work except the Jasper Console link from the Spectrum web page. The customer can still access the Jasper Console using by bookmarking or typing in the link. This will prevent the issue from occurring again. 

Additional Information