DX Netops Portal failing to sync with DX Netops Spectrum
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DX Netops Portal failing to sync with DX Netops Spectrum

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Article ID: 244876

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

Spectrum failing to sync with DX Netops Performance Management.

On the NetOps Portal (CAPC), in the DMService.log errors similar to the following are generated:

INFO   | jvm 1    | TIMESTAMP | CAPC encountered an error while trying to sync with data source Spectrum Infrastructure Manager@HOSTNAME.  The problem is in CAPC, not the data source.  The following stack trace shows the invalid SQL statement in CAPC:
INFO   | jvm 1    | TIMESTAMP | org.springframework.dao.DuplicateKeyException: PreparedStatementCallback; SQL [INSERT INTO dst_device_life_cycle_state (SourceID, LocalID, ItemID, LifeCycleState, UpdatedOn) VALUES(11,'0x00e00c7','111061675','MAINTENANCE',1654766031),
~~~~~~~~~
INFO   | jvm 1    | TIMESTAMP | (13,'0x1072c70','85744444','MAINTENANCE',1623456031)]; Duplicate entry '13-0x1072c70' for key 'dst_device_life_cycle_state.PRIMARY'; nested exception is java.sql.SQLIntegrityConstraintViolationException: Duplicate entry '13-0x1072c70' for key 'dst_device_life_cycle_state.PRIMARY'
INFO   | jvm 1    | TIMESTAMP |  at org.springframework.jdbc.support.SQLErrorCodeSQLExceptionTranslator.doTranslate(SQLErrorCodeSQLExceptionTranslator.java:247) ~[spring-jdbc-5.3.18.jar:5.3.18]

Environment

DX NetOps Spectrum & Performance Management, All Supported Releases

Cause

The nomal sync process is:

  1. Spectrum sends lifecycle state changes, we store the values.

  2. Global sync runs, and processes them and then clears the table where the values in 1 are stored.

  3. Next sync cycle we repeat #1.

If global sync is interrupted or is not completing successfully the table is never cleared and you can see the messages above.

Resolution

Let the global sync complete successfully without interruption.
The errors will clear on their own during the normal sync process.

If for some reason the Global sync does not complete, or the error persists, open an issue with Support for further investigation.