We have a problem deleting alarms, the clear is very slow, it takes a long time for the alarm to be deleted from the oneclick console, it takes about 15 or 20 seconds.
We were testing how to resolve it and in one test we stopped DNS and the issue was resolved, but we need to have the DNS started.
How we can resolve It?
Release : 21.2.x
Component : Spectrum Alarm
When Clear Alarm Action is triggered, login user email id or user name is passed as part of host name which is internally passing to VBrokerCorbaHelper to prepare appname and using InetAddress.getByName( hostName ), which is calling through DNS and causing delay.
Will be fixed in the next Spectrum release to be out of box in 22.2.1
DE534330
Cause:
When Clear Alarm Action is triggered, login user email id or user name is passed as part of host name which is internally passing to VBrokerCorbaHelper to prepare appname and using InetAddress.getByName( hostName ), which is calling through DNS and causing delay.
Solution
Provided support to pass user email id which is used to send email (From), so it will not effect host name/DNS call
If email id is not provided or not available(null), then logged in user name will be used as email id.