The Symantec Endpoint Security Agent Fails to Install When a Proxy is Present
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The Symantec Endpoint Security Agent Fails to Install When a Proxy is Present

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Article ID: 244644

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Updated On:

Products

Endpoint Security

Issue/Introduction

When attempting to install the Symantec Endpoint Security (SES) agent in an environment with a proxy, the installation fails. The popup gives no error code and attempts to check and reconfigure the proxy settings on the local server operating system also fail to resolve the problem.
 
 
You navigate to the FSD logs on the box according to the article linked here for clues. The FSD logs from the client show the following:
 
Line  73: 2022-06-23-10-02-49-296 : 0x1BB4 : Error : fsd::CWinHTTPEngine::getDownloadSize(942) : Query() failed, hr=0x80072EE2
Line  74: 2022-06-23-10-02-49-296 : 0x1BB4 : Error : fsd::CWinHTTPEngine::getDownloadSize(923) : Exhausted proxy attempts, falling back to direct connection
Line  75: 2022-06-23-10-03-10-336 : 0x1BB4 : Error : fsd::CWinHTTPEngine::getDownloadSize(942) : Query() failed, hr=0x80072EE2
Line  76: 2022-06-23-10-03-10-336 : 0x1BB4 : Error : fsd::CWinHTTPEngine::getDownloadSize(1009) : Got a WinHTTP connect or timeout, treating as a transient error so we will retry
 
Line 140: 2022-06-23-10-08-55-951 : 0x1BB4 : Information : fsd::FSDJob::OnDownloadEvent(238) : eDownloadFatalError
Line 142: 2022-06-23-10-08-55-966 : 0x1BB4 : Information : fsd::FSDJob::run(998) : jobState==eDownloadError
Line 153: 2022-06-23-10-08-55-966 : 0x1BB4 : Error : fsd::FSDJobEngine::OnJobEvent(748) : Handling eJobFinish failure, engine state=-2  job failed with hrJob=0x80047EC6
 
Line 192: 2022-06-23-10-09-02-672 : 0x1668 : Information : FSD exited. Error code: 3
 
 

Environment

Release : 14.3 RU4

Component : Default-Sym

Cause

The proxy configuration of the SES System Policy has not been configured and applied correctly.

 

Resolution

1. Navigate to the System Policy for the group in the SES console.

2. Reconfigure the proxy settings according to your environment.

3. Assign the new policy to the group.

4. Deploy a new installer package for the group.

A test of the new installation package succeeds in resolving the problem.