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GCP Login through Single Sign On is very slow.

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Article ID: 244464

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

You are receiving reports of it taking a long time to get into Clarity.

Users report slowness in the application, but only when trying the initial login.

The user hits the URL cppm1234.ondemand.ca.com and from there it goes to login.broadcom.com/########

and just stays here for a long time.

Other Symptoms:

The app-access logs report really long times to download .css and .js files.

client ip Timestamp URL Http Status Duration (milliseconds) Bytes Sent Session ID
240.0.2.139 22/Jun/2022:00:30:56 -0700 GET /pm/js/ppm-lib-optimized-dcb2a41089.min.js HTTP/1.1 200 1663412 263 -
240.0.2.132 22/Jun/2022:00:30:49 -0700 GET /niku/ui/uitk/gwt/com.ca.clarity.Gantt/6D7EBC5621B11D71BB75CFF46939C104.cache.js HTTP/1.1 200 499896 84 11399229__3475CC4D-D8C0-41E1-BC65-529AE3562607

 

Using Chrome Developer Tools there is a delay reflected on "https://login.broadcom.com/######".

For example:

Environment

Release : 16.0.2

Component : Clarity with Single Sign On in a GCP environment

Cause

Your Identity Provider may be experiencing an issue or be overloaded.

Resolution

Open a Support Case with Clarity Technical Support and also an Support ticket within your organization to check whether there are any IDP service disruptions.

Attachments