API keys from Portal are not synched with Gateway OTK database
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API keys from Portal are not synched with Gateway OTK database

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Article ID: 244436

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

customers are experiencing trouble with synching API keys from the Portal API to the OTK database.

Since they have upgraded the Portal to version 5.0.2, not all API keys form the portal are visible in the OTK database. Some API's do not work anymore because of this.

The ssg log shows the following error 

13T09:29:00.284+0200 WARNING 304 com.l7tech.external.assertions.gatewaymanagement.server.ServerRESTGatewayManagementAssertion: 9050: Error processing management request: An authenticated user is required but not present

Environment

Release : 5.0.2

Component :

Cause

After the upgrade the gateway portal integration is using the portal enhanced portal sync.

The api key are not synced anymore using the scheduled task , but portal will send a message to gateway using activemq which contains the apikey update.

The gateway will apply this update to the gateway using the local restman service.

 

Resolution

The portal sync is posting a updated bundle to the local restman service and to authenticate it require client authentication .

The authentication is done by client authentication , check the listing port configuration for port 8443 and 9443 make sure client authentication is not set to none but at least to "optional".