Error: No schedule information returned for AgentBasedPolicySerializer item. This is probably because no schedule information has been defined or the schedule is disabled.
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Error: No schedule information returned for AgentBasedPolicySerializer item. This is probably because no schedule information has been defined or the schedule is disabled.

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Article ID: 244427

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer noticed the following messages in the NS logs when trying to import software to MDM (Modern Device Management):

No schedule information returned for AgentBasedPolicySerializer item: 'Jabber' (e96b6eb9-01a1-4e65-a416-cfff5d091f10) This is probably because no schedule information has been defined or the schedule is disabled.

Supplied xml file 'E:\Altiris 8.0 Client Management suite\Workspaces\Api\uploads\34c1ec95-7a13-4031-bd2f-f318073ee1df\CiscoJabberMac-12.8.2.302955.pkg' is not valid

File : E:\Altiris 8.0 Client Management suite\Workspaces\Api\uploads\34c1ec95-7a13-4031-bd2f-f318073ee1df\CiscoJabberMac-12.8.2.302955.pkg is not valid xml.

Environment

ITMS 8.6 RU2

Cause

These messages are Trace level and internal. Our process is just trying to identify different types of Installation Files.

Resolution

These messages are by design for now and they are logged as Trace (these are not Errors/Warnings). These messages are not impacting functionality and can be ignored as they are Trace level and not an Error or Warning. 

When a package is importing, our code tries to understand what package we have and tries to parse files for different installation file types, doing it one by one until the type is found. If the type does not match, it writes the Trace information to the log saying that "type is not matching because package is not valid XML". When type matches, it does not write anything to log. That's why we see these messages - it is just one of many attempts to identify the package installation file type.