What happens when the base license expires on a ProxySG device and what would be the result of that license expiration?
search cancel

What happens when the base license expires on a ProxySG device and what would be the result of that license expiration?

book

Article ID: 244360

calendar_today

Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

What happens if the base license expires on a ProxySG device? 

Cause

When the base license expires, the appliance stops processing requests, and a license expiration notification message is logged in the Event Log.

In addition, for services set to Intercept:

  • In a transparent deployment, if the default policy is set to Allow, the appliance acts as if all services are set to Bypass, passing traffic through without examining it. If the default policy is set to Deny, traffic to these services is denied with an exception.
  • In an explicit deployment, regardless of the default policy setting, traffic to these services is denied with an exception.
  • If a base license expires, you won't be able to use the appliance so VPM won't come into play.

 Exceptions Due to Base License Expiration:

In some cases, the following exceptions occur when the base license expires:

  • HTTP (Web browsers) - An HTML page is displayed stating the license has expired.
  • An exception page appears when an HTTPS connection is attempted, but only if the appliance is deployed explicitly or in the case of transparent
  • FTP clients - If the FTP client supports it, a message is displayed stating the license has expired.
  • Streaming media clients - If the Windows Media Player, RealPlayer, or QuickTime player version supports it, a message is displayed stating the license has expired.
  • Unified Agent/ProxyClient - After the license has expired, remote clients cannot connect to the Internet or ADN network. (Unified Agents do not support the ADN network.)
  • You can still perform configuration tasks through the CLI, SSH console, serial console, or Telnet connection. Although a component is disabled, feature configurations are not altered. Also, policy restrictions remain independent of component availability.

Resolution

Contact Customer Care or Sales Rep to renew license.