Filtering on Staffing Workspace, Allocations Timeline for Custom Investments not showing all data
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Filtering on Staffing Workspace, Allocations Timeline for Custom Investments not showing all data

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Article ID: 244163

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When using the Staffing screen and have filters on (but no selections made), it is already filtering out the unstaffed items. 

The issue is reproduced when you simply add a string field to the filter section and don't put any criteria *AND* you have picked 1 specific Investment Type. For example, pick a Custom Investment Type to see both staffed and unstaffed investments, instead of the default 'All Staffed Investments'. Add the Common Investment Name or Description field to the Filter Section and don't enter any text to search. Navigate away and return - no investments are shown. Records are shown when 'All Staffed Investments' is used in this scenario. Records are shown when using fields of other data types like the Common Investment Manager name. 

 

Steps to Reproduce: 

  1. Create a Custom Investment or go to an existing Custom Investment
  2. Add two Investments (Inv A; Inv B)
  3. Add Staff to Inv A
  4. Go to Staffing Module on the left side menu
  5. Click Allocations Timeline
  6. Select Allocations By Investment
  7. Switch 'All Staffed Investments' button to Select the Custom Investment Type 
  8. Click Filter Icon
  9. Select Name(Common Investment) - leave blank
  10. Select Staff OBS Unit - leave blank
  11. Save View
  12. Click off the page
  13. Go back to the Staffing page
  14. Select view

Expected Result - Shows all investments under Custom Investments since there is nothing in the filters

Actual Result - Shows only investments that have Staff

Additionally- 

  1. Click on the Filter icon
  2. Delete one of the fields 

Expected Result -  Shows all investments

Actual Result - There are no investments showing

Environment

Release : 16.0.2

Component : Clarity MUX UI Usability

Cause

DE65481

Workaround: Delete the blank filter fields. 

 

Resolution

This has been fixed in 16.1.0