Agentless monitoring stopped working after upgrade from 8.5 RU3 to RU4
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Agentless monitoring stopped working after upgrade from 8.5 RU3 to RU4

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Article ID: 244149

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Updated On:

Products

IT Management Suite

Issue/Introduction

In this case, the Remote Monitor Service (RMS) was installed only on the Notification Server.

When looking at the Real-Time Performance Viewer (Actions > Monitor) and selecting a computer that is targeted by an agentless metrics policy you will either not see any agentless metrics available if agent based metrics are enabled for the computer, or if not, you will get an error saying, "Failed to connect the Monitor Plug-in. The Monitor Plug-in Service may be initializing or not running. Please retry in a few minutes and verity that Monitor Service is installed and running on the machine."

Environment

Release: 8.5 RU4

Cause

The Altiris Monitor Agent failed to register as a service on the RMS. In Services.msc, this service is called Altiris Monitor Agent and is set to Manual and to run as the Local System Account. 

AexMetricProv.exe was not running, and it would crash shortly after starting when run manually.

Resolution

Ran the following commands to register AexMetricProv.exe as a service

Navigate to the Altiris Agent > Agents > Monitor Agent 

Run these two commands at a command prompt:

  • aexmetricprov.exe /RegServer
  • aexmetricprov.exe /Service

Refresh Services.msc and verify that Altiris Monitor Agent is present

Verify that Real-Time Performance Viewer will show agentless metrics

Note in one case we needed to start AexMetricProv.exe manually; this showed as running as the logged on user, but within 10-15 seconds, a second instance started running as Local System and the logged on user instance terminated. We were then able to see agentless metrics and expected alerts resumed. After rebooting the Notification Server, the AexMetricProv started normally when viewing real time metrics.