Office365 endpoint without MFA configured has stopped working or endpoint cannot be acquired
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Office365 endpoint without MFA configured has stopped working or endpoint cannot be acquired

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Article ID: 244037

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

Office365 endpoint without MFA configured has stopped working or endpoint cannot be acquired

Environment

All Identity Manager

Cause

Microsoft is rolling out an update to Office365 tenants to require EXO v2 module which causes the below response to be included in the PowerShell response and breaks the Office365 connector:

New update available!
You are using an older version of Exchange PowerShell cmdlets which may be using (soon to be deprecated) Basic authentication.
Please install version 2.0.6 of the ExchangeOnlineManagement module to upgrade to the latest version of cmdlets, which are REST based, more secure, reliant and performant than the remote PowerShell cmdlets that you are currently using.

For more information on the latest cmdlets released, visit: https://techcommunity.microsoft.com/t5/exchange-team-blog/exchange-online-powershell-v2-module-preview-now-more-secure/ba-p/2922946

Resolution

Configuring and enabling the MFA support on the Office365 endpoint forces the connector to use the EXO v2 module and resolves the problem.

IM 14.4 has the MFA feature already included with the Office365 Connector. Customers would need to follow the steps mentions in the product documentation to install the EXO v2 module for PowerShell and configure and enable the MFA feature.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-management-and-governance-connectors/1-0/connectors/microsoft-connectors/microsoft-office-365/connect-to-office-365.html

IM 14.3 has the MFA feature provided as a Hotfix which can be downloaded from the following link

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-manager/14-3/Release-Notes/Hotfixes.html#concept.dita_298206a1-df7a-4a02-9d44-a28606d33d6b_Office365

https://support.broadcom.com/web/ecx/solutiondetails?aparNo=99111529&os=WINDOWS-ALL