search cancel

EM can't connect to PostgresSQL Database after upgrade to PostgreSQL13.x

book

Article ID: 243967

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Downloaded the PostgresSQL 13.7 and followed the instructions.

https://knowledge.broadcom.com/external/article/228491

Postgres 13.7 is running, but the EM can't connect to it.

If stop I PostgreSQL 13.7  and start the PostgreSQL 9.6 , the EM connects just fine to PostgreSQL 9.6

 

Environment

Release : 10.7.0

PostgreSQL 13.7 

Component : Introscope

Cause

Unsupported / Compatibility 

Resolution

APM 10.7 .x supports PostgreSQl 9.6.2.  

APM 10.8 supports PostgreSQL  9.6.2,  11,  and 13.4,13.6,13.7.

Please refer the updated compatibility guides .

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/CA-Application-Performance-Management-Compatibility-Guides/2146?r=2&r=1&r=1&r=1

Additional Information

The APM 10.8 Guide lists Postgres 13.8.

The 13.8 was a typo and the Compatibility Guide was updated.