search cancel

SQL Server DWH Database Compatibility

book

Article ID: 243908

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

I recently upgraded Clarity to 15.9.3.

When attempting to restore the 15.9.3 DWH schema, we receive the following error message:

The database was backed up on a server running version 14.00.3335
That version is incompatible with this server, which is running version 13.00.5102.

We are running MSSQL Version 2016.

Environment

Release : 15.9.3

Component :

Resolution

According to the release notes MSSQL 2016 is supported for upgrade only:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/clarity-project-and-portfolio-management-ppm-on-premise/15-9-3/release-information/Hardware-and-Software-Compatibility-Specifications.html

The reason for this distinction is that you can use a preexisting database, that was upgraded to 15.9.3, but the default schema that we provide will not work in SQL 2016.

If you wish to use the 15.9.3 schema files provided in the media, the database will need to be upgraded to MSSQL 2017 or 2019 (the exact certified patch levels are noted in the link above) after the upgrade is completed.