search cancel

Cannot install Linux agents on version '21.0.2+build.31' - Agent doesn´t start

book

Article ID: 243901

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Linux agent fails to start on v21 even after all certificates are in place

20220519/090628.589 - U02000004 Connection to Server 'USJ01#CP004' successfully created.

20220519/090628.589 - U02000297 Agent doesn't have valid certificate, requesting new one from server.

20220519/090628.590 - U02000300 Error during handling Private Key: 'LOAD/PEM_read_PrivateKey(/opt/apps/uc4/temp/AgentSecurityFolder/HOELDHZSAP02A.pem)'.

20220519/090628.590 - U02003073 Agent Prozess 'AGENT,PID=159415' shutdown has been initiated.

20220519/090628.632 - U02000041 Shutdown Agent 'HOELDHZSAP02A'.

20220519/090628.632 - U02000002 Agent 'HOELDHZSAP02A' version '21.0.2+build.31' ended abnormally.

 

Environment

Release : 21.0.2

 

Resolution

Using an .ini file from a older version can cause this issue. Make sure to replace the agent .ini when upgrading to v21