Secure proxy not working after upgrade - SSL protocol error
search cancel

Secure proxy not working after upgrade - SSL protocol error

book

Article ID: 243858

calendar_today

Updated On:

Products

SITEMINDER CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

 

After upgrading CA Access Gateway (SPS) from 12.8.2 to 12.8.6 users are seeing the following error while trying to access an application:

The connection for this site is not secure samplehost.example.com sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

 

Cause


The Apache component of Access Gateway had an invalid configuration where the virtual host definition was not in the same port as the Listen directive.

The discrepancy existed after the upgrade is unknown, as the upgrade logs were clean.

 

Resolution


Examine the <installation_folder>/secure-proxy/httpd/conf/extra/httpd-ssl.conf file and make sure the port(s) listed for any virtual hosts matches the port assigned to the Listen directive.