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Symantec Linux Agent fails to connect with Error code 20: HttpTransportNetworkError

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Article ID: 243828

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Updated On:

Products

Endpoint Security Complete

Issue/Introduction

Upon installation, the Symantec Linux Agent shows a server connection error. 

Communication status:

  server connection    failed

In cafagent.log, you see the following:

[|] 2022-06-08 17:13:44 | cafservice.SAEPErrorHandling | Error | 13801 : 140360143537920 : HandleError:203 | Request result data is NULL or empty
[|] 2022-06-08 17:13:44 | cafservice.SAEPErrorHandling | Error | 13801 : 140360143537920 : HandleError:204 | The error code is: 20
[|] 2022-06-08 17:13:44 | cafservice.SAEPErrorHandling | Error | 13801 : 140360143537920 : HandleError:205 | Error message: HttpTransportNetworkError
[|] 2022-06-08 17:13:44 | cafservice.SAEPErrorHandling | Error | 13801 : 140360143537920 : HandleError:206 | Error details:{"0":{"0":"ProxyModeDefault (8)","1":"EpmpClientErrorCodes: HttpTransportNetworkError (20)","2":{"0":"generic","1":110,"2":"Connection timed out"}},

Cause

Connection issues after installation are generally caused by a firewall block to either https://usea1.r3.securitycloud.symantec.com or to one of the Digicert revocation servers.

Resolution

Ensure that you allow traffic to all of the Symantec servers listed here.

In addition, be sure to allow traffic to the DigiCert certificate revocation servers outlined in the DigiCert documentation