Error exporting agents to csv from the CCS Console when selecting the "Export Agents as CSV" from the Agents workspace
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Error exporting agents to csv from the CCS Console when selecting the "Export Agents as CSV" from the Agents workspace

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Article ID: 243824

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Updated On: 11-07-2023

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

When I try to export all my current registered agents from the Agents View to a .csv file, I get the error "Error exporting agents to csv.  Refer to the log file for error details. 

Need to know why this is happening and where is the log file that is referenced.  

In the log files on the Symantec Application Server Service.

%ProgramData%\Symantec.CSM\Logs\AppServer\AppServer.Service.<datetime>.<pid>.<logfile#>.csv

You will see an entry like this.

2022-06-14 14:40:08.347,2022-06-14 10:40:08.347,<hostname>,Warning,DispatchProtocol.Common,AppserverService,6536,,180,HandleError,,0,0,"FaultErrorHandler - Fault: System.ServiceModel.Dispatcher.NetDispatcherFaultException: The formatter threw an exception while trying to deserialize the message: There was an error while trying to deserialize parameter http://example.org/:objIn. The InnerException message was 'There was an error deserializing the object of type Symantec.DispatchProtocol.Common.DispatchObjectData. The maximum array length quota (92160) has been exceeded while reading XML data. This quota may be increased by changing the MaxArrayLength property on the XmlDictionaryReaderQuotas object used when creating the XML reader.'.  Please see InnerException for more details. ---> System.Runtime.Serialization.SerializationException: There was an error deserializing the object of type Symantec.DispatchProtocol.Common.DispatchObjectData. The maximum array length quota (92160) has been exceeded while reading XML data. This quota may be increased by changing the MaxArrayLength property on the XmlDictionaryReaderQuotas object used when creating the XML reader. ---> System.Xml.XmlException: The maximum array length quota (92160) has been exceeded while reading XML data. This quota may be increased by changing the MaxArrayLength property on the XmlDictionaryReaderQuotas object used when creating the XML reader.

Cause

One or more Agents have a lot of data in their properties, overflowing the maxArrayLength for the XML Reader.

Resolution

To resolve this issue follow the steps below.

  1. Stop the Symantec Application Server Service.
  2. Open task manager and wait until the AppserverService.exe process is no longer running.
  3. Make a backup copy of the AppserverService.exe.Config at <InstallDir>\Application Server\
  4. Edit the AppServerService.exe.Config file
  5. Find the 2 entries for "maxArrayLength" under the <bindings> section.
  6. Change the value from 92160  to 2147483647.
  7. Save and close the file.
  8. Restart the Symantec Application Server Service

Now when you try to export the Agents to a CSV from the CCS Console the export will be successful.