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After upgrade to 14.0.2 still getting PEC ec=9 errors

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Article ID: 243796

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

After installing SCM v14 and applying the 14.0.2 patch, we find we will go for a few days with no problem, then one or two hserver processes will start returning PEC ec=9 errors for every Checkin and Checkout.  Killing those processes and letting the broker start new ones seems to be the only workaround.  Is there any way to resolve this?

Environment

Release : 14.0

Component : CA HARVEST SCM CORE FUNCTIONALITY/PROCESS AUTOMATION

Cause

Analysis of the log files showed:

- For the affected hserver processes, once the ec=9 errors started, no successful checkins or checkouts were seen after that.

- Users who experienced failed checkins or checkouts on the affected hserver(s) had successful checkins and checkouts on other hservers.

- Killing the affected hserver processes and letting the broker spin up new ones seems to be the only workaround.

Resolution

EFix was provided.