Unable to login into Management Center
Getting error as service is not ready to set request
Having investigated the reported error, "service is not ready to set request", and found that the license showed up as expired, from the backend entitlement server, the asset does have a valid entitlement. For the cause and resolution of the issue, please refer to the below.
Cause:
For the cause of the issue, there are two schools of thought:
[2015-05-29 12:11:35.212] ERROR pool-4-thread-1 com.bluecoat.cm.clp.CLPActivator Unable to retreive license, {} java.text.ParseException: Unparseable date: ""
at java.text.DateFormat.parse(DateFormat.java:357)
at com.bluecoat.cm.clp.license.License.toDate(License.java:89)
at com.bluecoat.cm.clp.CLPActivator$1.run(CLPActivator.java:71)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:304)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:178)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
[2015-05-29 12:11:35.213] WARN pool-4-thread-1 com.bluecoat.cm.clp.CLPActivator
License information is invalid or missing, system will shutdown in 24 hour
Resolution
In both cases, the fix would be to download/generate and install a new license. During the session, we did just that and then restarted the appliance, to restore access to the Management Center management console (GUI).