E03020191: <filename>.<version> not in the working view.
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E03020191: <filename>.<version> not in the working view.

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Article ID: 243514

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Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

A package in the "Prod" state contains the highest version of  <filename>.<version> .

When we try to check this file out for update from the "UT" state we get this error:

E03020191: <filename>.<version> not in the working view. The version does not exist in the working view.

 

 

Environment

Harvest Software Change Manager all versions

Cause

Harvest is designed in such a way that each state has its own data view containing any files that were included in the baseline at the beginning of the project, as well as any versions of files that were created in, or have passed through that state.  When a package is promoted into a state, the files in that package are "added" to the data view for that state.  When a packaage is demoted out of a state, the files in that package are "removed" from the data view for that state.

In this case, the version of the file in question had never "passed through" the state from which the user wanted to check it out.  Either it was checked into the package in a later state, or was added via cross project merge in a later state, or the state was "skipped over" as the package was being promoted.

To remedy the problem, the user needed to cause the package to "pass through" the state.  We accomplished this by promoting the package containing his version of the file to the state they needed, then promoting it back to it's original location.

 

 

Resolution

In this example, the package in question had never passed through the "UT" state so we must create 2 new processes:

  • A new process in the "Prod" state that promotes to the "UT" state
  • A new process in the "UT" state that promotes to the "Prod" state
  1. Login to the Harvest Administrator Tool, navigate to the project in question

  2. In the "Prod" state expand "Processes", right click and select "New Process" and "Promote Process".  Provide a name for the new process, and in the "Promote To" field select the "UT" state.  Click "Apply".  Select the "Access" tab and provide the appropriate access permissions so that the user can promote the package they want to the "UT" state.  Click "Apply" and "OK".

  3. In the "UT" state expand "Processes", right click and select "New Process" and "Promote Process".  Provide a name for the new process, and in the "Promote To" field select the "Prod" state.  Click "Apply".  Select the "Access" tab and provide the appropriate access permissions so that the user can promote the package they want to the "Prod" state.  Click "Apply" and "OK".

  4. Let the user login to Workbench.  

  5. Have them navigate to the "Prod" state, select their package and promote it to the "UT" state.  

  6. Have them navigate to the "UT" state, select their package and promote it back to the "Prod" state.

After completing these steps they should be able to check out the file for update from the "UT" state.

If desired, after this corrective action has been completed, the new processes created in steps 2 and 3 can be deleted.

 

Additional Information