Outlook Web Access (OWA) does not auto-update the Inbox
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Outlook Web Access (OWA) does not auto-update the Inbox

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Article ID: 243506

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Updated On:

Products

ProxySG Software - SGOS Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

The Outlook Web Access (OWA) inbox longer automatically updates to show new email messages that have arrived since the page was initially loaded. Users must manually refresh the page to see new incoming emails. The issue occurs after migrating to Cloud SWG or upgrading to SGOS to 7.x. 


More information:

  • The issue only occurs when SSL interception and/or the CASB Gatelet covering Outlook Web Access are enabled.
  • Disabling SSL inspection or the CASB Gatelet is a temporary workaround to the problem.

 

Cause

Changes introduced in SGOS 7.x disrupt the long-polling connection used by Outlook Web Access. Long-polling connections are commonly used by web applications to maintain a persistent connection between a client web browser and the application server to facilitate service-to-client “push” communications.

Resolution

For Cloud SWG (formerly known as WSS), please contact support.

For SGOS 7.x, create a CPL layer using VPM and add the following policy: 

<proxy> 
url.prefix=https://outlook.live.com/owa/0/notificationchannel/connect http.response.response_data.prevent_inspection_delay(yes)

If this does not work, the URL needed for your Office 365 tenant may differ from the one in this article. Contact support for assistance.

After installation of this policy, Outlook Web Access will auto update the inbox properly.