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REST API stopped working after upgrading WAMUI

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Article ID: 243423

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Updated On:

Products

SITEMINDER

Issue/Introduction

After a clean installation of the WAMUI, the REST API-based scripts stopped working. The previous version remains working.

The session key token is issued but for any other actions it responds 401 and writes the attached log "SMRESTAPI_004-Unable to decrypt the JWT token."

Environment

Release : 12.8

Component : SITEMINDER WAM UI

Cause

  • The version of the policy server does not match the version of the WAMUI.
  • The schema of the policy store was not updated to match the latest version.

Resolution

  • Confirm the version of the policy server matches the version of the WAMUI.
  • Import the schema to the policy store to update the schema for the version of the policy server.

 

If neither of these options work, gather a debug smrestservices.log for further troubleshooting.