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Unable to login to ALM from ARD studio

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Article ID: 243403

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Updated On:

Products

CA Agile Requirements Designer

Issue/Introduction

From ARD Studio 3.1.1.2, unable to login to ALM it shows " HTTP 0: Unreachable. Please check your URL ".

This was working one week before.

Cause

This issue most probably happened due to the update done to WinSCP software in ARD machine which uses the OpenSSL framework that is used by ARD as well and modified the supported TLS versions.

The TLS version supported by ARD 3.1.1.2 is TLS 1.1. If the WinSCP update changed the OpenSSL supported TLS version that doesn't include TLS 1.1 then this issue would occur.

Environment

Release : 3.1.1.2

Component : GT HP ALM Integration

Resolution

We can check the TLS supported versions of WinSCP from below instructions in below link and update the range to include TLS 1.1.

- https://winscp.net/eng/docs/ui_login_tls

Note: Such connectivity issue involving HTTPS connection may arise due to changes done to OpenSSL framework by updates done to any other software as well. Hence, it is recommended to keep track of the software upgrades done on ARD machines for easy debugging of the issues.