DCI9980E: CPC IN HMC CONFIG NOT FOUND error returned on DCI agent log
search cancel

DCI9980E: CPC IN HMC CONFIG NOT FOUND error returned on DCI agent log

book

Article ID: 243280

calendar_today

Updated On:

Products

Dynamic Capacity Intelligence

Issue/Introduction

On a Dynamic Capacity Intelligence (DCI) Agent DCILOG the following error message (DCI9980E) is returned:
DCI9980E: CPC IN HMC CONFIG NOT FOUND

 

Environment

Release : 2.0

Component : DYNAMIC CAPACITY INTELLIGENCE

Cause

Incorrect SAF authorizations for the DCI Agent

Resolution

Before issuing the DCI9980E error message, the Agent returned a DCI0999E error also:

DCI2100I: INIT: RETRIEVE CPC INFORMATION                        
DCI0999E: ERROR HWILIST  : (00000000/00000F02)                  
DCI0999E: ERROR HWILIST  : 00000000 00000000 00000000 00000000
DCI2197W: DCI AGENT GOT NO CPC INFORMATION.                  
DCI2199W: DCI AGENT NOT SET UP TO HANDLE HMC REQUESTS.    

Or:

DCI2100I: INIT: RETRIEVE CPC INFORMATION  
DCI0999E: ERROR HWILIST  : (00000000/00000304)
DCI0999E: ERROR HWILIST  : 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
DCI2197W: DCI AGENT GOT NO CPC INFORMATION. 
DCI2199W: DCI AGENT NOT SET UP TO HANDLE HMC REQUESTS.

 

So HWILIST callable service got a return code that can be found on the IBM documentation (HWILIST — Retrieve HMC and BCPii configuration-related information):

  • F02, which means "The user does not have correct SAF authorization for the request." (HWI_NO_SAF_AUTH).
  • 304, which means "There is no data to be returned or the caller does not have enough access to display the listed values." (HWI_LIST_NODATA_RETURNED).  

So, in both the cases, there are some external security authorizations that are not correctly set up.    

On the DCI 2.0 documentation, there is a section dealing with the external security requirements for DCI agents: Configure Security for BCPii Enabled Agents