GEN Studio does not start
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GEN Studio does not start

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Article ID: 243218

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Updated On:

Products

Gen - Workstation Toolset

Issue/Introduction

When trying to open GEN Studio, it does not launch and produces a '.log' file within '%USERPROFILE%\AppData\Local\CA\Gen 8.6\cfg\GenStudio\workspace\.metadata'

The .log file contains java error references to the Gen Studio plugin files located in 'C:\Program Files (x86)\CA\gen86\Gen\GenStudio\plugins'

An example where the plugin 'com.ca.gen.studio.common.help' could not be resolved: 

ENTRY com.ca.gen.studio.common.help 4 0 
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.ca.gen.studio.common.help [10]
Another singleton bundle selected: osgi.identity; osgi.identity="com.ca.gen.studio.common.help"; type="osgi.bundle"; version:Version="8.6.0.05663"; 

Environment

Release: 8.6

Component: Eclipse Gen Studio

 

Cause

One potential cause is that Gen Studio was installed both product/PTFs on one machine and the changes were deploying to another machine, this may result in multiple versions of the plugins on the deployed machine.   

Resolution

The problem is related to Gen Studio plugin versioning issues.

Verify whether there are duplicate and/or older versions of the plugins in the Gen studio plugin folder 'C:\Program Files (x86)\CA\gen86\Gen\GenStudio\plugins'.    Remove the duplicate/older versions of plugin may resolve the issue.

Also, before starting Gen Studio, remove the directories of '/Workspace' and '/Configuration' from within ''%USERPROFILE%\AppData\Local\CA\Gen 8.6\cfg\GenStudio' to clear out old plugin references.